Hi...My stuff...

List and Update your System. Make your own thread, and post away.
User avatar
austinstephens
Newbie
Posts: 36
Joined: Wed Mar 25, 2009 8:33 am
Location: Memphis, TN

Hi...My stuff...

Post by austinstephens » Wed Mar 25, 2009 8:55 am

Greetings..

I've been a Carver fan since 1990 when I purchased a pair of Amazings from a friend, who foolishly purchased a pair of "Maggies".. (A month later he was asking if I would be interested in selling the Carvers back..Ahh, No!) I drove them with an old Soundcraftsman power amp that worked it's ass off trying to drive the demanding loads of the Amazings. What a beautiful sound the speakers produced. The amp finally died one evening in a puff of smoke to the crescendo of ELP's Tarkus..Next I purchased an Adcom 5500 power amp..It did fair, but again, just couldn't drive the low impedance loads..But I do have to admit, that thing got hotter than Chernobyl and never once shut down!!!!

Finally, I purchased a Carver C-1 preamp and a TFM 55 power amp..This set up sounds absolutely wonderful..The Adcom cannot hold a candle to the 55's imaging and soundstage, not to mention the raw power it produces. My source is a California Audio labs DX-1 CD player..

After reading of the cheap bell wire Bob used in his speakers, I broke out the saw horses, a soldering iron, a schematic and rewired the speakers and crossovers with 14 gauge Monster. I also replaced the wood screws holding the grilles on with rivnut inserts and real 10-32 screws. My living room looked like the Carver plant!! I was a little nervous when I fired them up after the rewire, I was either lucky or good, because they sounded great!! I have had the usual problems with breaking ribbons. I have repaired them myself using conductive tape that we use in the aviation/avionics industry. But, I will soon be looking to have them rebuilt.

I enjoy this site, and am looking forward in sharing thoughts, opinions and ideas...

Rock on...

Mark
Attachments
1.jpg
Original Amazings, TFM-55 Amp, C-1 Preamp, California Audio Labs DX-1 CD Player..Simple and clean, but sounds so good!!!
1.jpg (54.7 KiB) Viewed 2585 times
2.jpg
TFM-55
2.jpg (51.63 KiB) Viewed 2586 times
3.jpg
California Audio Labs DX-1
3.jpg (55.97 KiB) Viewed 2585 times
4.jpg
4.jpg (49.23 KiB) Viewed 2585 times
5.jpg
Ran out of room!!! (Don't worry!! There is a stop in front of the speaker, a 22 lb single hand barbell. I removed it for the pic. It does a great job of protecting the speaker from the patio door, and it's still usable!! Oh the benefits of being single!!!!
5.jpg (47.87 KiB) Viewed 2587 times
Last edited by austinstephens on Wed Mar 25, 2009 4:26 pm, edited 17 times in total.
"Despite all the amputations, she could dance to a rock and roll station, and it was all right"....Lou Reed

User avatar
thuffman03
!! CarverFest Evictee !!
Posts: 2701
Joined: Fri Sep 19, 2008 10:07 am
Location: Pittsburgh, PA

Re: Hi...My stuff...

Post by thuffman03 » Wed Mar 25, 2009 9:36 am

Welcome to the forum. You have a very nice setup. I am sure it sounds great. Cool looking dragon!
Some cool Carver stuff!

User avatar
engtaz
"TAZ"
Posts: 5385
Joined: Sat Jun 30, 2007 1:43 pm
Location: Tampa, FL

Re: Hi...My stuff...

Post by engtaz » Wed Mar 25, 2009 10:53 am

Very nice setup.
engtaz


Carver M4.0T in front channels to Caver AL VI's in SACD & 2 Channel setup
C 16, PT 2400, Slim Device, Carver TX-8, 490T and Rega TT w Grado Gold cart in the 2 channel setup
Bogen SRB20 is computer amp
Carver PM-350 donated for youth church use

puchalsk
Newbie 50+
Posts: 53
Joined: Sat Feb 21, 2009 10:37 am
Location: Ontario, Canada

Re: Hi...My stuff...

Post by puchalsk » Wed Mar 25, 2009 1:57 pm

Welcome Mark!
M1.5T (2), M400, TFM-15, C-1,C4000, CT-6

Jag_97470
SILVER-7 TUBE AMP
Posts: 3369
Joined: Fri Sep 19, 2008 12:06 am
Location: Oregon

Re: Hi...My stuff...

Post by Jag_97470 » Wed Mar 25, 2009 3:28 pm

Welcome austinstephens! Very clean set-up, but I hope the door doesn't keep hitting the speaker? Welcome again.

User avatar
austinstephens
Newbie
Posts: 36
Joined: Wed Mar 25, 2009 8:33 am
Location: Memphis, TN

Re: Hi...My stuff...

Post by austinstephens » Wed Mar 25, 2009 4:20 pm

Jag_97470 wrote:Welcome austinstephens! Very clean set-up, but I hope the door doesn't keep hitting the speaker? Welcome again.
Thanks..If that door ever hit the speaker, it's coming off the hinges!!! \:D/ \:D/
"Despite all the amputations, she could dance to a rock and roll station, and it was all right"....Lou Reed

Jag_97470
SILVER-7 TUBE AMP
Posts: 3369
Joined: Fri Sep 19, 2008 12:06 am
Location: Oregon

Re: Hi...My stuff...

Post by Jag_97470 » Wed Mar 25, 2009 7:42 pm

austinstephens wrote:
Jag_97470 wrote:Welcome austinstephens! Very clean set-up, but I hope the door doesn't keep hitting the speaker? Welcome again.
Thanks..If that door ever hit the speaker, it's coming off the hinges!!! \:D/ \:D/

Say what fire Marshal inspector? Why is there "no front door" for a main fire escape?
And why did I seal up the exit creating a solid wall? Hello! The door kept hitting my speaker!! Duh!
LOL

User avatar
t-mitch4
M-400t CUBE
Posts: 199
Joined: Sun Feb 03, 2008 8:55 pm
Location: Vancouver Island, BC, Canada

Re: Hi...My stuff...

Post by t-mitch4 » Wed Mar 25, 2009 8:05 pm

Nice set up. Clean & simple =D>

Tom

User avatar
austinstephens
Newbie
Posts: 36
Joined: Wed Mar 25, 2009 8:33 am
Location: Memphis, TN

Re: Hi...My stuff...

Post by austinstephens » Wed Mar 25, 2009 8:24 pm

Jag_97470 wrote:
austinstephens wrote:
Jag_97470 wrote:Welcome austinstephens! Very clean set-up, but I hope the door doesn't keep hitting the speaker? Welcome again.
Thanks..If that door ever hit the speaker, it's coming off the hinges!!! \:D/ \:D/

Say what fire Marshal inspector? Why is there "no front door" for a main fire escape?
And why did I seal up the exit creating a solid wall? Hello! The door kept hitting my speaker!! Duh!
LOL
That's right dammit...A man must set his priorities!!!

Thanks for the welcome!! Glad to be here!!!
"Despite all the amputations, she could dance to a rock and roll station, and it was all right"....Lou Reed

User avatar
kingman
(pair of) SILVER-7 TUBE AMPs
Posts: 6359
Joined: Sun Nov 30, 2008 2:10 pm
Location: Upstate South Carolina

Re: Hi...My stuff...

Post by kingman » Wed Mar 25, 2009 10:18 pm

I like your system...the TFM-55 kicks ass!!! 8)
In reality, it only matters what it sounds like to YOU!!!

User avatar
ViperZ
M-400t CUBE
Posts: 119
Joined: Mon Sep 08, 2008 8:11 pm
Location: Toronto, ON, Canada

Re: Hi...My stuff...

Post by ViperZ » Thu Jun 04, 2009 3:28 pm

Nice and very clean setup. I love when people post photos rather just putting up a list of what they own. 8)

User avatar
stevewithrow
SILVER-7t
Posts: 1315
Joined: Mon Aug 25, 2008 12:59 am
Location: Great NorthWest.....Carver Country..

Re: Hi...My stuff...

Post by stevewithrow » Fri Jun 05, 2009 9:34 am

=D> =D> =D> =D> =D> =D>

User avatar
ranster
Newbie
Posts: 49
Joined: Thu Nov 02, 2006 12:59 am
Location: california

Re: Hi...My stuff...

Post by ranster » Sun Mar 14, 2010 2:03 am

hi were you ever able to match up the binding posts from your amp with any cardias as the one in my a-760x was replaced at the shop but i left it in the box for nearly a year before i opened it up and now its too late to send back and i dont have another 500 dollars to spend to have them fix it again
1,A-760x, 2, Sonics Asscts. from the IMAX theater 800x's these are the bryston 7B's but kicked up .i have added two bryston 7B's and a tfm-25 running through a Sunfire TGP I: and a Krell KAV 500i. 2, magnapan tympani 1 b's main-- 2 Polk rt 11t's secondary mains--2 Polk RT1000p's for centers and sub and one audiophile 10 cube subwoofer 2 Polk rti 150's running from the sevin axis connector just for more meat in the middle and 2 polk audio rt55i with changed crossovers from the polk audio RT3000p

User avatar
TNRabbit
R.I.P. Friend
R.I.P. Friend
Posts: 13360
Joined: Sun Jan 14, 2007 11:53 am
Location: TN Native Languishing in VA
Contact:

Re: Hi...My stuff...

Post by TNRabbit » Sun Mar 14, 2010 7:43 am

Nice!

Welcome, Mark~
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

User avatar
Scarabeo
SILVER-7 TUBE AMP
Posts: 2608
Joined: Tue Nov 18, 2008 6:05 pm

Re: Hi...My stuff...

Post by Scarabeo » Mon Mar 15, 2010 12:25 am

VERY, VERY NICE!!!
I have the same Audio & TV stands as you - LOVE EM! in fact I have 2 of each but had to move my Audio equipment on the TV stands, See Avitar to left...
BillD, You will be forever with us! RIP until we meet again on the other side...

Post Reply

Return to “List / Update Your System”