FAQ  •  Register   •  Gallery •  Login

It is currently Wed Nov 26, 2014 6:06 pm

Now they work .. now they don't..

<<

lehmannfarm

Newbie

Posts: 3

Joined: Thu Feb 18, 2010 9:59 am

Post Thu Feb 18, 2010 6:39 pm

Now they work .. now they don't..

Hi I'm a new member of this fine forum of gents.. :-) I'm Danish, but it's real hard to get adequate info overhere.. I have a pair of platinums that have been in storage for some years. Now I reentered them in my new home, but but but.. they worked fine first, then on the left side the ribbons became silent.. next day the same .. then they all of a sudden worked for 2-3 days and now again not.. I'm not technical but removed the front and back covers to check for any smell or obvious bad connections.. nothing apparently.. any suggestions pls pls..?? :-) It's too evil to rediscover just how much you love their sound and then this..

Tommie
<<

Scarabeo

User avatar

SILVER-7 TUBE AMP

Posts: 2655

Joined: Tue Nov 18, 2008 6:05 pm

Post Thu Feb 18, 2010 6:45 pm

Re: Now they work .. now they don't..

Have you checked the FUSE to the Ribbons? or around the terminals??? Do the woofers work all the time or do they too cut in and out and/or have you hook them to another system amp/pre amp etc?
BillD, You will be forever with us! RIP until we meet again on the other side...
<<

lehmannfarm

Newbie

Posts: 3

Joined: Thu Feb 18, 2010 9:59 am

Post Thu Feb 18, 2010 7:04 pm

Re: Now they work .. now they don't..

I'm only aware of the fuse situated right next to the terminals..? the woofers work fine at all times.. I'm not sure I understand the last question.. #-o :)
<<

treitz3

User avatar

"Julian"
"Julian"

Posts: 7746

Joined: Mon Oct 16, 2006 5:39 pm

Location: The tube lair in Charlotte, NC

Post Thu Feb 18, 2010 7:09 pm

Re: Now they work .. now they don't..

Hello and welcome to the Carver forum from North Carolina, USA.

What kind of storage conditions were they kept in, if you don't mind me asking? Now, to the ribbon....have you looked up and down the ribbons with a fine tooth comb [not literally] to check and see if there is a hairline crack on any part of the traces?
In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

The best way to enjoy digital music reproduction is to never listen to a good analogue reproduction.

Robert R. - "Did you see my North Korea analogy? I should have named it Carversite.kim"
<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13342

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Thu Feb 18, 2010 10:30 pm

Re: Now they work .. now they don't..

I agree with treitz3; it sounds as though there is a short somewhere in the ribbon trace material.
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.
<<

lehmannfarm

Newbie

Posts: 3

Joined: Thu Feb 18, 2010 9:59 am

Post Fri Feb 19, 2010 3:48 am

Re: Now they work .. now they don't..

a bit uneven, and wrinckled but no cracks.. strange thing.. if I put an xtra wiring from the xover into the poles connecting the 2 ribbon units, both plays.. but apparently the original connection in the bottom of the ribbons is ok, but then again it can't be or?!? pls remember you are talking an imbecil, but carver-sound loving person.. :-)
<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13342

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Fri Feb 19, 2010 4:23 am

Re: Now they work .. now they don't..

Perhaps a short in your crossover, then?
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

Return to Carver Speakers

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2011 phpBB Group.