FAQ  •  Register   •  Gallery •  Login

It is currently Tue Oct 21, 2014 8:38 am

got silvers today but!!!!!

<<

Chuck1

Newbie 50+

Posts: 70

Joined: Tue May 18, 2004 6:36 pm

Post Fri Mar 19, 2010 11:44 am

Re: got silvers today but!!!!!

The resistor must have got smokin hot at one time for the outer casing to become so brittle and crumble away. I would not drive them without repairing the resistor / and checking other components first.
I was planning on a complete "oil-rubdown" on my silver's this weekend, but the weather here is supposed to be great, so I may not have a chance to get them done. If I do, I will check the crossover network resistor values.
<<

BillD

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 7295

Joined: Wed Jun 06, 2007 8:29 pm

Location: The west's most mid-western town, Scottsdale, Arizona

Post Fri Mar 19, 2010 11:44 am

Re: got silvers today but!!!!!

It looks to me to be a Rev. E crossover, especially if that obscured letter on the iron core inductor is a 3. RR4 and R5 were omitted in Rev E. The presence of R3 would indicate that it has the CT woofers. Also, the values of the 47µF caps (C1 and C2) changed after Rev. E. It's got to be either R1 or R2, and in that R2 is bigger than R1, I'm guessing that it's a 2Ω 75W resistor (and R1 is a 2Ω 10W resistor). That would leave R3 as a 1Ω 50W resistor. The iron core inductor (L1) should be 10mH and the air core inductor (L2) should be 2.5mH. Oh, the yellow cap (C3) should be 22µF 100V. I think that accounts for all the parts.
It should sound like it isn't there!
There is a difference between hearing and listening...
Making life enjoyable through expensive electronics.
_________________
Carver: C-4000 & C-1 preamps, PSC-60 preamp/tuner, TX-11a tuner, M-400 (2), C-500, M-500, M-500t, M-500t Mk.II, A-500x, AL-III loudspeakers (2 pr.)
Sunfire:Theater Grand III processor, Ultimate Receiver, Cinema Grand Signature 400 ~ seven, True Subwoofer Mk. II, D-10 Subwoofer
<<

F1nut

User avatar

SILVER-7 TUBE AMP

Posts: 4561

Joined: Tue Nov 11, 2003 3:31 am

Location: The Mars Hotel

Post Fri Mar 19, 2010 12:29 pm

Re: got silvers today but!!!!!

carver most certainly does make a 2.0t its the pm 2.0t.


Hmmm...I stand corrected.
Political Correctness...defined

A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end.



In a recent press conference, President Obama remarked, "If I had a city, it would look just like Detroit."
<<

mmmadog

Newbie

Posts: 13

Joined: Sat May 02, 2009 1:07 pm

Post Fri Mar 19, 2010 2:13 pm

Re: got silvers today but!!!!!

Yes they are the 3 woofer silvers. My next question was going to be are these the original woofers. I will post a pic later. Iam located in the olympia area. I have to have something internally changed on the 2.0t because I was using it bridged. I dont think the 2.0 is anywhere near a 1.5 for one the 2.0 only ways 10lbs has a clip eliminater seperate gains for each channel and a fan. You have to plug it in and wait 2 or 3 minutes before you can turn it on. I have a buddy that if I can get him to set the pipe down long enough is good at fixing electronics. If we can get the right part maybe its an easy fix. Thanks for all the info so far. Very helpful. Will keep you posted...............................Matthew
<<

fstik

M-400t CUBE

Posts: 138

Joined: Tue Jun 28, 2005 8:34 pm

Location: The Palm Beaches, FL

Post Fri Mar 19, 2010 3:01 pm

Re: got silvers today but!!!!!

I have a set of Silver crossovers in the newbie for sale section. Shoot me a pm if you are interested.

fstik
<<

mmmadog

Newbie

Posts: 13

Joined: Sat May 02, 2009 1:07 pm

Post Sat Mar 20, 2010 1:10 pm

Re: got silvers today but!!!!!

When I listened to these speakers before I bought them they got real loud but not much bass. I just assumed it was the little integrated amp he was using. Iam using a sunfire symphonic pre I just got and now a bgw750c. When you turn it up they use alot more gain from the pre than other setups I have and not much sound. Real flat and seems like somethings holding them back. I email a guy Bob Crities. He is know for the work he does on klipsch speakers and modifies there crossovers. He emailed me right back this mourning and I sent him the picture and the info you guys had givin me. Again he emailed me right back and said no problem fixing these. He said the big resisitor may be hard to find and the large value caps would be very expensive unless we use the electrolytics like the originals. I tell ya just listening at low levels these are going to be killer when done. My car stereo sounds real harsh and grainy after listening to these..................Matthew
Previous

Return to Carver Speakers

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2011 phpBB Group.