Awful Smell From My Amazings

Carver Speaker Discussions and Questions
tah800
TFM-25
Posts: 395
Joined: Sun Mar 07, 2004 9:26 pm
Location: Sussex,New Brunswick, Canada

Awful Smell From My Amazings

Post by tah800 » Fri Jul 30, 2010 1:06 pm

Was checking out my surround system today. Put in the movie Polar Express. At the beginning of this movie the train pulls up at the kids house. Might have had it up at bit to loud. Anyway the grills on my amazings started to billow out and the meters on my silver 9t's were banging against the maximum side of the amps. Hit the volume button once I realized what was happening but suddenly this awful smell filled the room. When I checked at the back of the speakers I could small this burnt odor. Wonder what I cooked. They seem to be still working. Could it have been the crossover. One other time when I had too much bass energy The leads inside the woofers came together and created a short. The crossover then heated up and smelled terrible. The difference was they didn't seperate the first time and they shut down the woofers. This time all the woofers seem to be active. Maybe the wires just came together when that particular sequence in the movie took place and the woofers were really moving forward. If I take them apart what should I check for??? Never thought I could get enough bass energy to have that happen. Art.

User avatar
treitz3
"Julian"
"Julian"
Posts: 7805
Joined: Mon Oct 16, 2006 5:39 pm
Location: The tube lair in Charlotte, NC

Re: Awful Smell From My Amazings

Post by treitz3 » Fri Jul 30, 2010 1:31 pm

Art, disassemble the speaker from rear to front and inspect the crossover. You should have some sort of residue either on the board itself or from the capacitor(s) or the bigger resistor. Post a photo of your findings, please.
In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

The best way to enjoy digital music reproduction is to never listen to a good analogue reproduction.

User avatar
BillD
R.I.P. Friend
R.I.P. Friend
Posts: 7126
Joined: Wed Jun 06, 2007 8:29 pm
Location: The west's most mid-western town, Scottsdale, Arizona

Re: Awful Smell From My Amazings

Post by BillD » Fri Jul 30, 2010 1:32 pm

I'm guessing the crossover caps. Take the back off and look to see if there is electrolyte spilled (needs to be cleaned up and caps replaced). Was the smell musty? Any smoke?
It should sound like it isn't there!
There is a difference between hearing and listening...
Making life enjoyable through expensive electronics.
_________________
Carver: C-4000 & C-1 preamps, PSC-60 preamp/tuner, TX-11a tuner, M-400 (2), C-500, M-500, M-500t, M-500t Mk.II, A-500x, AL-III loudspeakers (2 pr.)
Sunfire:Theater Grand III processor, Ultimate Receiver, Cinema Grand Signature 400 ~ seven, True Subwoofer Mk. II, D-10 Subwoofer

tah800
TFM-25
Posts: 395
Joined: Sun Mar 07, 2004 9:26 pm
Location: Sussex,New Brunswick, Canada

Re: Awful Smell From My Amazings

Post by tah800 » Fri Jul 30, 2010 2:06 pm

Got he backs off. Surprisingly I can't see anything burnt or blackened. Maybe I got lucky and they just heated up enough to stink. I stilll wonder if the two leads from the bass speakers came together just long eough to cause a short and heat up the crossovers. The honeycomb front of the woofers must have really come forward if I noticed the grillcloth billowing out. Think its time for me to get a good sub.

User avatar
TNRabbit
R.I.P. Friend
R.I.P. Friend
Posts: 13360
Joined: Sun Jan 14, 2007 11:53 am
Location: TN Native Languishing in VA
Contact:

Re: Awful Smell From My Amazings

Post by TNRabbit » Fri Jul 30, 2010 2:24 pm

Art...WTF?!? Who were you trying to impress this time? :lol:

I'd check the impedance also; if you burned any section of the voice coil, it will lower your impedance, possibly dangerously (for the amps).
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

User avatar
kingman
(pair of) SILVER-7 TUBE AMPs
Posts: 6368
Joined: Sun Nov 30, 2008 2:10 pm
Location: Upstate South Carolina

Re: Awful Smell From My Amazings

Post by kingman » Fri Jul 30, 2010 3:49 pm

THE MAGIC "SMELL" APPEARS!!!!...Smokin the Amazings!!!! :shock: :shock:
In reality, it only matters what it sounds like to YOU!!!

User avatar
beemers417
!! CarverFest Evictee !!
Posts: 1381
Joined: Tue Dec 30, 2008 3:05 pm
Location: Pittsburgh, PA
Contact:

Re: Awful Smell From My Amazings

Post by beemers417 » Fri Jul 30, 2010 3:54 pm

That happens here from time to time. :lol: :lol: :lol: :lol:
Gunter the wonder dog is watching you...

User avatar
helicopterpilotdoug
(pair of) SILVER-7t's
Posts: 2200
Joined: Sun Mar 21, 2010 8:04 pm
Location: Austin TX
Contact:

Re: Awful Smell From My Amazings

Post by helicopterpilotdoug » Fri Jul 30, 2010 5:22 pm

kingman wrote:THE MAGIC "SMELL" APPEARS!!!!...Smokin the Amazings!!!! :shock: :shock:
I've heard of smoke that was amazing, but never heard of smoking amazings. That must be some really downer stuff man! Don't want a hit off that pipe man! :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol:
Sunfire: Theater Grand IV, Cinema Grand Signature.
Carver: TFM-45, PST-24 Cassette, Extra Carver Gear: CT-6, C-11 (S/N 00001).
Polk Audio: Mains SRS 2.1TL, Center CSiA6, Surrounds FXiA6 and FXiA4, Sub DSW MicroPro 1000, Extra Speakers SDA 2A, SDA 2Btl, Monitor 10A.
Turntable: Dual CS 714Q
Bluray/SACD: Oppo BDP 83SE
CD: Sony 330 300 Disk changer

http://www.douglasconnection.com

megasat16
TFM-25
Posts: 357
Joined: Wed Dec 17, 2008 11:13 pm

Re: Awful Smell From My Amazings

Post by megasat16 » Fri Jul 30, 2010 7:53 pm

I fed my pair of Amazings Plats with bi-amping setup with Technics SE-A3 on the low end and Denon POA-3000 on the ribbons. I think I was testing the pre (Aragon Aurum) at that time so I played Hotel California on repeat.

For some reasons, I got a sudden urge to see how my amps can handle the Plats. I cranked and cranked and cranked more. No sweat for my amps. But when the needle hits 200W (8 ohms readings) on the meter of SE-A3, I heard fart fart fart from one of the speakers. I immediately turned off the volume and looked at my plat. Sure enough, one speaker got a damaged woofer from over excursion. Damn, there goes my $50 bucks. #-o

Another one of Amazing story to brighten the OP day! As others suggested, take a look at the XO and check the resistance of the ribbon and woofers.

Good Luck fixing it!

tah800
TFM-25
Posts: 395
Joined: Sun Mar 07, 2004 9:26 pm
Location: Sussex,New Brunswick, Canada

Re: Awful Smell From My Amazings

Post by tah800 » Sat Jul 31, 2010 8:43 am

How do you check the resistance of the ribbon and woofers.???????????????

User avatar
treitz3
"Julian"
"Julian"
Posts: 7805
Joined: Mon Oct 16, 2006 5:39 pm
Location: The tube lair in Charlotte, NC

Re: Awful Smell From My Amazings

Post by treitz3 » Sat Jul 31, 2010 9:48 am

I just unsoldered the wires leading to the speaker woofers and ribbon assembly at the crossover and measured from there. Do you remember what ohm rating you are looking for?
In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

The best way to enjoy digital music reproduction is to never listen to a good analogue reproduction.

User avatar
TNRabbit
R.I.P. Friend
R.I.P. Friend
Posts: 13360
Joined: Sun Jan 14, 2007 11:53 am
Location: TN Native Languishing in VA
Contact:

Re: Awful Smell From My Amazings

Post by TNRabbit » Sat Jul 31, 2010 10:23 am

You can do a preliminary impedance check AT THE TERMINAL CONNECTORS.

You should get around 4-5 ohms resistance. If it's lower, you've probably burned a voice coil. If higher, it's possible you've opened a circuit in one of the crossover caps. You can go from there, but that will give you at least an indicator. Post back what you find at the terminals connectors.
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

OconeeOrange
"Forum Troll"
"Forum Troll"
Posts: 3992
Joined: Sat Mar 28, 2009 6:24 pm
Contact:

Re: Awful Smell From My Amazings

Post by OconeeOrange » Sat Jul 31, 2010 3:42 pm

Before you go tearing your stuff up - 8-[

Last week I had the same problem with my great BOSE speakers. I panicked until I realized my Bride had farted near the bass tube.

User avatar
TNRabbit
R.I.P. Friend
R.I.P. Friend
Posts: 13360
Joined: Sun Jan 14, 2007 11:53 am
Location: TN Native Languishing in VA
Contact:

Re: Awful Smell From My Amazings

Post by TNRabbit » Sat Jul 31, 2010 9:48 pm

OconeeOrange wrote:Before you go tearing your stuff up - 8-[

Last week I had the same problem with my great BOSE speakers. I panicked until I realized my Bride had farted near the bass tube.

=D> =D> =D> =D> =D> =D>
:lol: :lol: :lol: :lol: :lol: :lol:
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

User avatar
beemers417
!! CarverFest Evictee !!
Posts: 1381
Joined: Tue Dec 30, 2008 3:05 pm
Location: Pittsburgh, PA
Contact:

Re: Awful Smell From My Amazings

Post by beemers417 » Sat Jul 31, 2010 10:33 pm

That is just wrong...You could have blamed it on the dog! =P~ =P~ =P~ =P~
Gunter the wonder dog is watching you...

Post Reply

Return to “Carver Speakers”