Platinum and Silver model woofers

Carver Speaker Discussions and Questions
User avatar
Zoot Horn
SILVER-7 TUBE AMP
Posts: 3550
Joined: Thu Nov 15, 2007 7:26 pm
Location: 4th Tower of Inverness

Re: Platinum and Silver model woofers

Post by Zoot Horn » Sun Aug 10, 2008 11:52 am

Well,,I got the "suspect" woofer out,,connected it to the speaker cables,, turned the volume up slowly,,and it started to distort at a very low volume. At this point I think that I will replace the drivers and upgrade the wiring when I do so,,I am however concerned at the lack of bass (IMHO).I picked up these speaks from the original owner,,they started out as originals,,received the "plat" upgrade,,as far as I can tell,they are wired correctly,, they have the 60 inch ribbons,plat crossover,,and the original drivers which I will replace with the swl 1220(IIRC) from the dynavox/orevox folks. I had a fleeting thought of dragging these to Carverfest to let some of the folks who are infinetely more experienced take a look at em,, but I think that I'll just take a break and wait until the replacements are installed.I do have one question,, when playing,, are the mid/drivers supposed to move?I am powering them with Adcom 565 monos. All for now,,I need a break--george

Late note---I pulled a woofer out of another set, much improved,, I'm still going to replace the woofs and upgrade the wiring. One thing that I've found ,, I believe that it's going to take more than the adcom mono's to really make the babies sing. I apologize for trouncing on this thread--all for now.

User avatar
skip
aka (Sasquach)
Posts: 1861
Joined: Tue Aug 29, 2006 3:47 pm
Location: Gaston, S.C.

Re: Platinum and Silver model woofers

Post by skip » Mon Aug 11, 2008 6:40 am

If you have a lack of bass response in your ALS, there is something wrong. Your testing uncovered at least one bad driver, so the rest probably aren't far behind. There could also be problems in the x-over. When you get your drivers replaced, you will need to run them for about 50 hours before they properly break in. At least, that's about how long it took mine. When I first hooked 'em up after installing all new drivers, I was disappointed with the bass response. It just sounded flat, with little punch. Each day it seemed to get a little better. Now I can feel as well as hear each bass note, no matter how soft or subtle. When they are right, the ALS speakers have the truest bass response I've ever heard in a speaker.
Sasquatch
TnRabbit's Assistant Official OCCD Enabler.

How long a minute is, depends on what side of the bathroom door you're on.

User avatar
Reese
TFM-75
Posts: 839
Joined: Tue Jun 21, 2005 7:33 pm
Location: Santa Fe NM

Re: Platinum and Silver model woofers

Post by Reese » Mon Aug 11, 2008 9:35 am

zoothorn wrote:Well,,I got the "suspect" woofer out,,connected it to the speaker cables,, turned the volume up slowly,,and it started to distort at a very low volume. At this point I think that I will replace the drivers and upgrade the wiring when I do so,,I am however concerned at the lack of bass (IMHO).I picked up these speaks from the original owner,,they started out as originals,,received the "plat" upgrade,,as far as I can tell,they are wired correctly,, they have the 60 inch ribbons,plat crossover,,and the original drivers which I will replace with the swl 1220(IIRC) from the dynavox/orevox folks. I had a fleeting thought of dragging these to Carverfest to let some of the folks who are infinetely more experienced take a look at em,, but I think that I'll just take a break and wait until the replacements are installed.I do have one question,, when playing,, are the mid/drivers supposed to move?I am powering them with Adcom 565 monos. All for now,,I need a break--george

Late note---I pulled a woofer out of another set, much improved,, I'm still going to replace the woofs and upgrade the wiring. One thing that I've found ,, I believe that it's going to take more than the adcom mono's to really make the babies sing. I apologize for trouncing on this thread--all for now.
I know that, while I enjoyed the Plats driven by my adcom 5800 stereo amp (250 w/ch into 8, 400 into 4, etc.) for several years (since the mid-90's); the difference in monoblocking with the Silver 7ts - then switching up to the Silver 9ts --- made a HUGE difference in bass quality and response, with of course probably equal improvements in the ribbon responses because of the power available for transients and the mid/upper range of classical and other music ranging beyond the usual middle range of a lot of rock/pop/dance music. I'm sure you're gonna love the eventual response from the Amazings with the adcom 565s and the improvements/replacements you're making.....but going for some more power into the Amazings would probably really make your toes curl!!!!
Too often we enjoy the comfort of opinion without the discomfort of thought -- JFK

Sunfire Classic Tube Preamp; 2 Carver Silver 7ts, 2 Silver 9ts; bi-amped ALS (Originals upgraded to Platinum), Rane PE15's eq's and Rane AC22 xcrossover; Carver c-19 tube pre;
Carver 390t CD carousel; Carver 490t CD player; BBE 362 Sonic Maximizer; C-9 SH; Sony ES tuner and DAT deck; Sony CD copier/burner; Sony dual cassette deck; TEAC 2340R 4 ch r to r tape deck; Dual CS5000 tt, Shure V15 Type V-MR cartridge

User avatar
skip
aka (Sasquach)
Posts: 1861
Joined: Tue Aug 29, 2006 3:47 pm
Location: Gaston, S.C.

Re: Platinum and Silver model woofers

Post by skip » Mon Aug 11, 2008 9:46 am

9t's do make a difference in that ALS sound \:D/ \:D/ \:D/
Sasquatch
TnRabbit's Assistant Official OCCD Enabler.

How long a minute is, depends on what side of the bathroom door you're on.

User avatar
Zoot Horn
SILVER-7 TUBE AMP
Posts: 3550
Joined: Thu Nov 15, 2007 7:26 pm
Location: 4th Tower of Inverness

Re: Platinum and Silver model woofers

Post by Zoot Horn » Mon Aug 11, 2008 3:59 pm

Thanks for the replies ,,at least I feel as though I'm taking the correct approach now,,, I'll post here after I get the replacements and wiring completed.I've got a pair of Odyssey Mono Extremes that I'll through in the mix and go from there.Thanks again.

User avatar
Robert R
TFM-75
Posts: 860
Joined: Tue Aug 05, 2008 2:05 pm

Re: Platinum and Silver model woofers

Post by Robert R » Tue Sep 23, 2008 4:15 pm

Just my two cents worth - when you're done messing with woofers, always take a 9v battery and check them for phase. It's all too easy to get one backwards, and that will definitely (note spelling!) reduce your bass.

RobertR
"You know what folks? I'm happy."

Mr. M-500t
(pair of) SILVER-7 TUBE AMPs
Posts: 6129
Joined: Fri Mar 17, 2006 10:00 pm

Re: Platinum and Silver model woofers

Post by Mr. M-500t » Thu Oct 23, 2008 10:17 pm

skip wrote:If you have a lack of bass response in your ALS, there is something wrong. Your testing uncovered at least one bad driver, so the rest probably aren't far behind. There could also be problems in the x-over. When you get your drivers replaced, you will need to run them for about 50 hours before they properly break in. At least, that's about how long it took mine. When I first hooked 'em up after installing all new drivers, I was disappointed with the bass response. It just sounded flat, with little punch. Each day it seemed to get a little better. Now I can feel as well as hear each bass note, no matter how soft or subtle. When they are right, the ALS speakers have the truest bass response I've ever heard in a speaker.
Hey Skip,
For reference in the future; what drivers did you buy for your Plats ?

User avatar
maddmaxxx
(Pair of Silver 9t's)
Posts: 2951
Joined: Wed Oct 27, 2004 6:18 pm
Location: the World We Skate Our 'Choppers' Thru

Re: Platinum and Silver model woofers

Post by maddmaxxx » Thu Oct 23, 2008 10:42 pm

Mr. M-500t wrote:
skip wrote:If you have a lack of bass response in your ALS, there is something wrong. Your testing uncovered at least one bad driver, so the rest probably aren't far behind. There could also be problems in the x-over. When you get your drivers replaced, you will need to run them for about 50 hours before they properly break in. At least, that's about how long it took mine. When I first hooked 'em up after installing all new drivers, I was disappointed with the bass response. It just sounded flat, with little punch. Each day it seemed to get a little better. Now I can feel as well as hear each bass note, no matter how soft or subtle. When they are right, the ALS speakers have the truest bass response I've ever heard in a speaker.
Hey Skip,
For reference in the future; what drivers did you buy for your Plats ?


-the wp-1220 [16ohmers for plats/ silvers]
-* © Küül ®™ /mx...
-Too hip gotta book
-"Don't BAN me Bro!"...el/doro

User avatar
speakerlabfan
TFM-55
Posts: 710
Joined: Mon Sep 22, 2008 10:19 am
Location: Seattle area

Re: Platinum and Silver model woofers

Post by speakerlabfan » Fri Oct 24, 2008 2:41 pm

Thought I'd jump in to report that I ordered and received shipment on the WP-1220 woofers from Dynavox for Amazing Silvers in the past week. They are $45/each. It was $30 on UPS ground to ship the 6 woofers up here. Very smooth experience with ordering these drivers.

...I'm looking forward to swapping in the new woofers tomorrow (maybe tonight). \:D/
Phase Linear Andromedas, 2000 II Pre, 5100 II Tuner
Carver Amazings - original and silver, M500t,C-1, C-4000, PM 1.5, M200t
Manley Stingray; Cambridge Audio DacMagic, 640p; Pro-ject Tube Box SE II
McIntosh MC2205, C28
JBL 4430, 4425, 4311B
Rega P5, Benz Micro Wood, Cary/AES AE-3 Preamp

Mr. M-500t
(pair of) SILVER-7 TUBE AMPs
Posts: 6129
Joined: Fri Mar 17, 2006 10:00 pm

Re: Platinum and Silver model woofers

Post by Mr. M-500t » Fri Oct 24, 2008 7:21 pm

Pictures Please !!!!!!!!! :) :) :)

User avatar
speakerlabfan
TFM-55
Posts: 710
Joined: Mon Sep 22, 2008 10:19 am
Location: Seattle area

Re: Platinum and Silver model woofers

Post by speakerlabfan » Sat Oct 25, 2008 12:04 pm

Mr. M-500t wrote:Pictures Please !!!!!!!!! :) :) :)
Ok will try to post a couple of pictures as I swap in the new woofers. Here's a cellphone camera shot from the other night when I unscrewed the old woofers. The x-overs are huge, everything looks clean and new (I'm used to looking at much old speakers).

Image
Phase Linear Andromedas, 2000 II Pre, 5100 II Tuner
Carver Amazings - original and silver, M500t,C-1, C-4000, PM 1.5, M200t
Manley Stingray; Cambridge Audio DacMagic, 640p; Pro-ject Tube Box SE II
McIntosh MC2205, C28
JBL 4430, 4425, 4311B
Rega P5, Benz Micro Wood, Cary/AES AE-3 Preamp

Mr. M-500t
(pair of) SILVER-7 TUBE AMPs
Posts: 6129
Joined: Fri Mar 17, 2006 10:00 pm

Re: Platinum and Silver model woofers

Post by Mr. M-500t » Sat Oct 25, 2008 12:33 pm

Fucking Cell Phones. :lol: :lol: :lol:
Pictures Please............................................................. :D

User avatar
speakerlabfan
TFM-55
Posts: 710
Joined: Mon Sep 22, 2008 10:19 am
Location: Seattle area

Re: Platinum and Silver model woofers

Post by speakerlabfan » Sun Oct 26, 2008 1:35 am

Yep, being lazy because it's a quick shoot and email to photobucket operation with the mobile phone. Ok, here's a couple real pictures....

The drivers are all in sequence on the same speaker wire (two red, two black leads) from the x-over, but it's interesting that each is connected differently.

The 1st driver (top, closest to the x-over) is connected with a single red and black on the + side and a single red and black on the - side.

The 2nd driver (middle) is connected with both red wires on the + side and both black wires on the - side.

The 3rd driver (bottom) is connected with a red and black lead on the + side and just a single black lead on the - side. I verified the drivers are connected like this on both speakers.

Image
Image
Phase Linear Andromedas, 2000 II Pre, 5100 II Tuner
Carver Amazings - original and silver, M500t,C-1, C-4000, PM 1.5, M200t
Manley Stingray; Cambridge Audio DacMagic, 640p; Pro-ject Tube Box SE II
McIntosh MC2205, C28
JBL 4430, 4425, 4311B
Rega P5, Benz Micro Wood, Cary/AES AE-3 Preamp

User avatar
Robert R
TFM-75
Posts: 860
Joined: Tue Aug 05, 2008 2:05 pm

Re: Platinum and Silver model woofers

Post by Robert R » Sun Oct 26, 2008 7:30 am

Yeah. The only sensible thing that I ever could see in the woofer hookup wire color scheme is the fact that at least each piece of wire is the same color at both ends.
"You know what folks? I'm happy."

User avatar
speakerlabfan
TFM-55
Posts: 710
Joined: Mon Sep 22, 2008 10:19 am
Location: Seattle area

Re: Platinum and Silver model woofers

Post by speakerlabfan » Sun Nov 09, 2008 1:06 am

The new woofers are in-place and wired correctly, and I have been doing some listening today in the (crowded) living room. The surrounds are getting a workout.

Listening to the Amazing silvers right now driven with a Carver M-1.5t and Nakamichi CA-5 control amp + ST7 tuner -- KPLU-FM "all blues" programming. Have also been listening to some jazz CDs. The speakers will go into a small downstairs room soon where I can work on placement.

These silvers can take all the 350 WPC amp can give and want more. I have a PM-1.5 amp I'm not using, so I am thinking about a configuration that uses both amps. The M-1.5t gets VERY hot.

Image
Phase Linear Andromedas, 2000 II Pre, 5100 II Tuner
Carver Amazings - original and silver, M500t,C-1, C-4000, PM 1.5, M200t
Manley Stingray; Cambridge Audio DacMagic, 640p; Pro-ject Tube Box SE II
McIntosh MC2205, C28
JBL 4430, 4425, 4311B
Rega P5, Benz Micro Wood, Cary/AES AE-3 Preamp

Post Reply

Return to “Carver Speakers”