Signature 600x2 issue....

Sunfire Home Audio (Stereo) Discussions and Questions
jstang
Newbie
Posts: 7
Joined: Wed Sep 30, 2009 10:15 pm
Location: Nothern Jersey....

Signature 600x2 issue....

Post by jstang » Sat Jun 28, 2014 10:03 pm

Hey there folks.... Hello.... I am a long time lurker....

I am working on a Signature 600x2 for my friend Eddie, he is on this site.... his is a long time Carver/Sunfire audiophile.... I am new to this site, but he is an old timer and visits Carver Fest ....

Anyways, I am looking for advice on a Signature 600x2 that had seeming had CAP go up in smoke and take out some small signal xtors... Take a look at the pics .... Any advice? Or schematics? Seen this before? I am guessing the cap blew, shorted and took out a few other parts...

Thanks,
Johnk

Image

Image

User avatar
frenchguy
SILVER-7 TUBE AMP
Posts: 2765
Joined: Fri May 14, 2010 11:53 pm
Location: wisconsin

Re: Signature 600x2 issue....

Post by frenchguy » Sat Jun 28, 2014 10:27 pm

what pics? :?: :-? :)
Carver Silver 7t mono blocks, Carver M-4.0t & 2 tfm 42,s. ct-6 & ct-17, sda390t,TX11 tuner, jolida jd 100A. JBL L96 & JBL 4401,s W/Ribbon Tweeters, Dared SL-2000A tube preamp, Dared MP-5BT Integrated vacuum tube amp, 2 sets of Carver Amazing Silver speakers, oak & black. Carver Cinema 5.1 subwoofer & Tesla audio Carverfest satellite ribbon speakers & stands & Douglas connection cables

User avatar
Eddie
Eddie The Knife
Posts: 1799
Joined: Sun May 15, 2005 7:03 pm
Location: Valhalla! Expect me when you see me!

Re: Signature 600x2 issue....

Post by Eddie » Sun Jun 29, 2014 8:57 am

Here is one of the channel boards!
Attachments
photo_1.jpeg
Don't waste a good opportunity to shut up!

Good judgment comes from experience, but experience usually comes from bad judgment.

The best thing is to learn from others that have mastered the one thing you need to learn!

I would tell you to go to hell but I already work there and I don't want to see your ugly face every day!

User avatar
frenchguy
SILVER-7 TUBE AMP
Posts: 2765
Joined: Fri May 14, 2010 11:53 pm
Location: wisconsin

Re: Signature 600x2 issue....

Post by frenchguy » Sun Jun 29, 2014 9:20 am

Ouch!! :shock: magic smoke!! #-o lots of damage there, dont know if that board can be repaired? [-o< :-k
Carver Silver 7t mono blocks, Carver M-4.0t & 2 tfm 42,s. ct-6 & ct-17, sda390t,TX11 tuner, jolida jd 100A. JBL L96 & JBL 4401,s W/Ribbon Tweeters, Dared SL-2000A tube preamp, Dared MP-5BT Integrated vacuum tube amp, 2 sets of Carver Amazing Silver speakers, oak & black. Carver Cinema 5.1 subwoofer & Tesla audio Carverfest satellite ribbon speakers & stands & Douglas connection cables

jstang
Newbie
Posts: 7
Joined: Wed Sep 30, 2009 10:15 pm
Location: Nothern Jersey....

Re: Signature 600x2 issue....

Post by jstang » Sun Jun 29, 2014 9:50 am

Odd I see the pics... Might be my loggin at the other site that allows that. Anyways thanks for reporting the pics... And yes to ouch....

Good news is I can just copy the other channels parts value, but a schematic sure would help.

And Wisdom/advice is never turned down....if someone has seen this issue before.

JohnK

User avatar
frenchguy
SILVER-7 TUBE AMP
Posts: 2765
Joined: Fri May 14, 2010 11:53 pm
Location: wisconsin

Re: Signature 600x2 issue....

Post by frenchguy » Sun Jun 29, 2014 9:56 am

pretty sure sunfire has never released schematics for any of their equipment!! ](*,) should be able to identify the pieces you need & replace though! :-k
Carver Silver 7t mono blocks, Carver M-4.0t & 2 tfm 42,s. ct-6 & ct-17, sda390t,TX11 tuner, jolida jd 100A. JBL L96 & JBL 4401,s W/Ribbon Tweeters, Dared SL-2000A tube preamp, Dared MP-5BT Integrated vacuum tube amp, 2 sets of Carver Amazing Silver speakers, oak & black. Carver Cinema 5.1 subwoofer & Tesla audio Carverfest satellite ribbon speakers & stands & Douglas connection cables

User avatar
Zoot Horn
SILVER-7 TUBE AMP
Posts: 3569
Joined: Thu Nov 15, 2007 7:26 pm
Location: 4th Tower of Inverness

Re: Signature 600x2 issue....

Post by Zoot Horn » Sun Jun 29, 2014 10:36 am

Damn,, what were you doing,, arc welding with it,,,seriously,,hope you get it repaired !

User avatar
radioeng2
SILVER-7 TUBE AMP
Posts: 2700
Joined: Fri Jan 26, 2007 7:06 pm
Location: E TN

Re: Signature 600x2 issue....

Post by radioeng2 » Sun Jun 29, 2014 10:46 am

My gut feel is overvoltage to the capacitor from something else failing. Looks kind of far away from the higher heat sources to be the first electolytic to give it up. I'd look real hard at all the semi-conductors there. Look for a likely path for voltage exceeding the cap rating.

Pull the same circuit caps in the rest of it and look at them real hard as a cross check. I'd consider wholesale replacement of the electrolytics though if it's time.

Wear out your VOM doing cross checks. Good luck!

Mark
I was there "At the Fest!" Hope you were too!

User avatar
jjptkd
SILVER-7 TUBE AMP
Posts: 3056
Joined: Wed Sep 22, 2010 4:50 pm
Location: Snohomish, WA

Re: Signature 600x2 issue....

Post by jjptkd » Sun Jun 29, 2014 11:54 am

So you ended up with the Silver 600 two that was on eBay... :-k :-k Good luck with the repair!
Oppo Sonica DAC
Sunfire TG-III
Sunfire 300x2
Klipsch Chorus II

jstang
Newbie
Posts: 7
Joined: Wed Sep 30, 2009 10:15 pm
Location: Nothern Jersey....

Re: Signature 600x2 issue....

Post by jstang » Sun Jun 29, 2014 11:58 am

Yup... One of the small signal xtor next to the cap are blown out too.... Chicken or egg?

I will clean and inspect it this evening, once Eddie stops calling me and asking "Is it fixed yet?" :D :D :D

JohnK

OconeeOrange
"Forum Troll"
"Forum Troll"
Posts: 3992
Joined: Sat Mar 28, 2009 6:24 pm
Contact:

Re: Signature 600x2 issue....

Post by OconeeOrange » Sun Jun 29, 2014 4:32 pm

I believe many can work on these, but while I mean no disrespect to you, Bill Flannery is the best available now.
http://www.flannerysvintageaudio.com/

In my opinion, the guy to contact before any Sunfire purchase or repair is Jessie. He is free help and knows his crap. The guy is an expert who is actually available =D> .
I have 7 Sunfire amp things (bidding on another against Jessie as I write this).

Anything I really want, I contact Jessie (jjptkd). He has a 100% satisfaction policy.

Looks like your motherboard is shot. You may have a unit to sell as parts on ebay as there is a market.

jstang
Newbie
Posts: 7
Joined: Wed Sep 30, 2009 10:15 pm
Location: Nothern Jersey....

Re: Signature 600x2 issue....

Post by jstang » Sun Jun 29, 2014 6:29 pm

Well all I really need is a schematic.... I will be good to go.... I have worked in the electronics field for 40 years.

There are burnt runs near that cap, even those can be repaired. It will be a little scared when done, but will sound just fine.

So I take it , this is not a common issue. Oh well....

JohnK

angelod307
SILVER-7 TUBE AMP
Posts: 2654
Joined: Sat Jun 06, 2009 10:56 pm
Location: manning, sc

Re: Signature 600x2 issue....

Post by angelod307 » Sun Jun 29, 2014 9:35 pm

The only people that have those schematics are as follows,sunfire, bob carver, bill Flanery I would think( do not know for sure) and tom at vintage hifi. That is it. Rolland most likely made a schematic as he also works on the. Sunfire. No one I know of has them to give. So. I may be a touch prejudice as I have had all four people work on my amplifiers at one point or another. They all are top rate. For me, my two lightstars are being rebuilt by Tom who also has that paper work as well. Hard choice, but I like the tom. Next would be Rolland, then bill and bob is way too busy.
CarverFest: I just go for the arts and crafts

angelod307
SILVER-7 TUBE AMP
Posts: 2654
Joined: Sat Jun 06, 2009 10:56 pm
Location: manning, sc

Re: Signature 600x2 issue....

Post by angelod307 » Sun Jun 29, 2014 9:38 pm

Curious, as I must have missed it, how much did a silver 600 cost you if you don't mind sharing?
CarverFest: I just go for the arts and crafts

User avatar
jjptkd
SILVER-7 TUBE AMP
Posts: 3056
Joined: Wed Sep 22, 2010 4:50 pm
Location: Snohomish, WA

Re: Signature 600x2 issue....

Post by jjptkd » Sun Jun 29, 2014 9:48 pm

I bid it up to $950 shipped and he out bid me by $10? Somewhere right around there, under $1k shipped. I would have bid more as I know this would be an easy fix for Bill as he has a stack of brand new replacement boards for this amp but I'm working too many hours right now to do any serious eBay battles. Bill is the man with the Sunfires as he has the schematics, parts and the experience. This probably would have been a $300 repair with less than a week turn around through Bill, just sayin'. :? :?
Oppo Sonica DAC
Sunfire TG-III
Sunfire 300x2
Klipsch Chorus II

Post Reply

Return to “Sunfire Home Audio”