FAQ  •  Register   •  Gallery •  Login

It is currently Sun Nov 23, 2014 3:51 pm

Problem with Pxm-450..Protect lights up (..at low volume..?)

<<

vince-jelly

Newbie

Posts: 2

Joined: Thu Oct 08, 2009 4:45 pm

Post Thu Oct 08, 2009 5:06 pm

Problem with Pxm-450..Protect lights up (..at low volume..?)

Hello to everyone!!
I'm new to this forum as I'm new to Carver pro audio (and pro amps in general..). Some days ago I bought a Carver power amp, the Pxm-450, from a shop which had it "new old stock" from I don't know how many years..today my tech and I tried to power it on with his keyboard, just to see if it worked..Well, the lights shows after 1-2 seconds (but maybe this is normal..).
But, after some minutes, when he was playing chords with the amp set in mono/bridge operation, 450 watts at 8 ohms, with the level knob at 12 o'clock, the red Protect light shows up and "cut" the sound, for lots of times..And it wasn't very loud I think, really..not 400+ watts at last..!
The Clip led never lights up though..
Is this normal? What kind of problem could be..?
Thanks to everyone who can help me..!!!!
..Please sorry for my english..!
<<

F1nut

User avatar

SILVER-7 TUBE AMP

Posts: 4561

Joined: Tue Nov 11, 2003 3:31 am

Location: The Mars Hotel

Post Thu Oct 08, 2009 9:56 pm

Re: Problem with Pxm-450..Protect lights up (..at low volume..?)

Welcome to CarverAudio.

Your English is better than some of the others that post here, so no worries.

As for your problem, sorry I can't help you and I'm not sure that anyone here can as the forum is more about home audio. That said, since it doesn't meet your needs I would suggest returning it for a refund.
Political Correctness...defined

A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end.



In a recent press conference, President Obama remarked, "If I had a city, it would look just like Detroit."
<<

vince-jelly

Newbie

Posts: 2

Joined: Thu Oct 08, 2009 4:45 pm

Post Fri Oct 09, 2009 3:02 am

Re: Problem with Pxm-450..Protect lights up (..at low volume..?)

Thanks for the reply!!
I think that I'd better return it as you say, but I'm going to mess with it just for some other days..the fact is that I've read in the manual that the Protect lights when there's an over-current at the Load (so, the problem should be at the output..), usually because of a faulty load..so maybe the problem could come from speakers and/or the impedance load..
As for sound, it was really ok, i think of quality..

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2011 phpBB Group.