FAQ  •  Register   •  Gallery •  Login

It is currently Fri Apr 18, 2014 4:13 pm

Carver M1.5t issues

<<

nadude98

Newbie

Posts: 7

Joined: Mon Nov 02, 2009 11:13 pm

Post Wed Nov 04, 2009 10:39 pm

Carver M1.5t issues

I just got a 1.5t off of Epray and I think it might have some issues... It doesn't sound quite as clear as my previous 1.0t did and I am wondering if it has the low end it should have.... biggest thing is the sonic quality. When I have the funds I plan to send it to Rita's if they are still around and still have the same deal...... [-o<

I opened it up and noticed some brown stuff aroud a cap on each of the power boards....not sure if it is normal or not. I also noticed it looked worked on recently? The thermal grease looked really new! When I did that I tried to match the big TO-2 transistors to see if they had new replacements and the schematic shows a listing for the chassis mounted transistors Q1-Q10 and what they should be... Well Q8 calls for a C6000 and Q6 calls for a 2SD555, and Q8 is also 2SD555 on this thing.... is the 2SD555 a replacement for the c6000's??? If not what is the proper replacement?
Attachments
carver 011.JPG
The amp boards showing the reverse side of the board, back of the electrolytics with the brown stuff....not what I usually see for glue!
carver 011.JPG (558.05 KiB) Viewed 459 times
<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13258

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Wed Nov 04, 2009 10:51 pm

Re: Carver M1.5t issues

It does look a little toasty.

Maybe time for a trip to Rita or Rolland~
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.
<<

stevewithrow

User avatar

SILVER-7t

Posts: 1327

Joined: Mon Aug 25, 2008 12:59 am

Location: Great NorthWest.....Carver Country..

Post Wed Nov 04, 2009 11:47 pm

Re: Carver M1.5t issues

Rita Helm and I (Bob Carver) have opened a new shop for fixing and restoring all vintage Carver Corp, Phase Linear and Sunfire audio equipment.
We also restore ALL vintage tube amps as well. Rita's Vintage Audio Repair.

Each unit will be repaired, updated and gone through from top to bottom, restored to the same performance and condition as it was the day it was built.

A flat fee of $175 dollars* + shipping covers it all. Our minimum inspection fee is $35 dollars.

The address is:
Rita Helm, Old Sunfire building
1920 Bickford Ave
Snohomish WA 98290

Phone 425-530-9557. Ask for Harry Abbott.


XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Updated post from another thread. This is from Lisa at Bob's repair shop..............and I quote.......

Hi Everyone,
I am Lisa from Rita's Vintage Audio Repair. Here is some helpful info:

Here is our info:

Rita's Vintage Audio Repair
1920 Bickford Ave.
Snohomish, WA 98290
360-568-4700
ritasvintageaudio@gmail.com

Our Charges:*

$195.00 Flat Fee
$175.00 for active drivers ONLY if it needs it
$75.00 for passive drivers ONLY if it needs it
$75.00 for tech labor time on unit over 3hrs.
$ 20.00 ONLY IF box & packing material are needed or wanted.
<<

nadude98

Newbie

Posts: 7

Joined: Mon Nov 02, 2009 11:13 pm

Post Fri Nov 06, 2009 10:06 am

Re: Carver M1.5t issues

Well, my plan is to send it there when I get my taxes back, but until then I was really wondering about those two transistors....

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 3 guests

cron
Powered by phpBB © 2011 phpBB Group.