FAQ  •  Register   •  Gallery •  Login

It is currently Wed Aug 20, 2014 7:23 pm

Advent (sunfire) AV550S Sub?

<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13292

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Thu Dec 03, 2009 8:57 am

Re: Advent (sunfire) AV550S Sub?

It's not uncommon to have a grounding issue that causes hum. Tighten all the internal & external nuts on the connectors & see if that reduces your hum.

BillD had a similar issue & found it to be an internal connector nut loose, if I remember correctly....

and WELCOME to the forum~
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.
<<

BillD

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 7295

Joined: Wed Jun 06, 2007 8:29 pm

Location: The west's most mid-western town, Scottsdale, Arizona

Post Thu Dec 03, 2009 11:27 am

Re: Advent (sunfire) AV550S Sub?

Yeah, but mine wasn't gain coupled. Still a good idea to tighten everything and hope for the best.
It should sound like it isn't there!
There is a difference between hearing and listening...
Making life enjoyable through expensive electronics.
_________________
Carver: C-4000 & C-1 preamps, PSC-60 preamp/tuner, TX-11a tuner, M-400 (2), C-500, M-500, M-500t, M-500t Mk.II, A-500x, AL-III loudspeakers (2 pr.)
Sunfire:Theater Grand III processor, Ultimate Receiver, Cinema Grand Signature 400 ~ seven, True Subwoofer Mk. II, D-10 Subwoofer

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2011 phpBB Group.