FAQ  •  Register   •  Gallery •  Login

It is currently Wed Apr 16, 2014 2:04 pm

TFM-45 Problem

<<

ferndog

Newbie

Posts: 5

Joined: Mon Jan 26, 2004 11:17 am

Post Wed Jan 28, 2004 11:44 am

TFM-45 Problem

The problem I'm having is that the sound from the left channel sounds dirty. The overall volume of the channel is a bit lower than the right one and compared to the right channel the highs are barely heard. I've swapped the interconnects and eliminated the CT-17 as the source. Any Ideas???

Thanks in advance.
<<

govcon

Newbie

Posts: 20

Joined: Sun Jan 25, 2004 10:02 am

Post Wed Jan 28, 2004 9:15 pm

Sounds like a channel in the amp is going down. Here's what happened with my TFM25. The amp would put out some high frequency distortion but particulary when the amp was cold. I had the amp serviced by Sunfire. Here's what they fixed from the comments on the repair order.

Replaced relays causing distortion & intermittent output.
Replaced pre-driver transistors ( x8 ) on both channels to stand up off of board to keep board from burning.
Touched up fractured solder.
Reset bias and bench test.

The repair cost me $220 (flat fee.) The cost of the repair was the same regardless of whether I sent the amp directly to Sunfire or letting my local Sunfire dealer send it in. I let the local Sunfire dealer do it because I didn't have the orginal boxes and also the dealer didn't charge me any shipping. Hopefully this gives you some insight. You can call Sunfire directly and ask the Carver repair person, Rita, what she thinks is wrong. She had guessed at some things that could have been wrong with my amp before I sent it in. She was almost spot on. Good luck.

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2011 phpBB Group.