m500-t blown drivers!need help!

If you have Carver repair questions, or can help other users with repairs, this is the place for it
Post Reply
raikkonen
Newbie
Posts: 7
Joined: Wed Apr 18, 2007 11:07 am

m500-t blown drivers!need help!

Post by raikkonen » Fri Apr 24, 2009 8:50 am

hi guys,
a friend gave it to me, i have the schematics, but a little help would be nice... :-k
the drivers near the power transistors, 2sa1111 and 2sa2592, are exploded. really.
then many resistors are burned...
i can tell you the resistor number in the next days, but i'd like to know if someone else experienced something like this, what hould i check and/or change and how to proceed...
thanks a lot in advance!

User avatar
BillD
R.I.P. Friend
R.I.P. Friend
Posts: 7126
Joined: Wed Jun 06, 2007 8:29 pm
Location: The west's most mid-western town, Scottsdale, Arizona

Re: m500-t blown drivers!need help!

Post by BillD » Fri Apr 24, 2009 9:53 am

Sometimes it's a cascading problem, a resistor here, a rectifier there and pow. With my M-500, I was loosing a rectifier in the feedback loop that controls the power rails. The voltage would just keep creeping up. The first thing it did was take out the caps (they were old and weak). I recapped the whole unit, and still had a problem, but the caps were strong enough to get me through the troubleshooting. You might give RichP714 a call (or PM), as he's the expert on the M-500(t) as well as the M-1.0t.
It should sound like it isn't there!
There is a difference between hearing and listening...
Making life enjoyable through expensive electronics.
_________________
Carver: C-4000 & C-1 preamps, PSC-60 preamp/tuner, TX-11a tuner, M-400 (2), C-500, M-500, M-500t, M-500t Mk.II, A-500x, AL-III loudspeakers (2 pr.)
Sunfire:Theater Grand III processor, Ultimate Receiver, Cinema Grand Signature 400 ~ seven, True Subwoofer Mk. II, D-10 Subwoofer

raikkonen
Newbie
Posts: 7
Joined: Wed Apr 18, 2007 11:07 am

Re: m500-t blown drivers!need help!

Post by raikkonen » Fri Apr 24, 2009 10:05 am

thanks BillD,
i'll start changing some old caps, this is for sure!
then whe have to change blown transistors and resistors, but i'm not sure if i have to change also power transistors and how to test the power supply.
Maybe i'll send a pm to Rich, to see if he can give me a hand...

birdyman
Newbie
Posts: 21
Joined: Sun Apr 26, 2009 7:52 pm

Re: m500-t blown drivers!need help!

Post by birdyman » Sun Apr 26, 2009 8:37 pm

Before you power up recheck your bias trim pot to at least middle position or minimal position to avoid blowing power transistors or local bias transistors and voltage control trim pot to minimum voltage. If you do not have Variac, you shoud connect 60~100w bulb to power cord( in serial of course) at NO speakrs or loads connected to it. 60w bulb will slow your unit from get ready even if it is ok. So wait few seconds to verify working condition of unit. Hope this helps

Post Reply

Return to “CARVER Equipment Repair/Help Forum”