Page 6 of 6

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 9:50 am
by BlueMDPicker
So, 8+ years later, how many amps and preamps were ultimately identified?

I still have both of mine driving a pair of Polk SDA 2B Studios in a recently put together 2CH listening room. The preamp (and original remote) still work flawlessly. The amp still sounds great, but has developed a slight left channel hum. Probably some power supply capacitors? And, the left VU meter illumination has gotten very bright (same issue as hum?) I'm in SW Florida now and doubt I'd roll the dice shipping it to the the NW or PA. May just take it apart and look everything over.

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 12:30 pm
by jjptkd
Everyone seems to be very tight lipped about their Lightstar gear. :-$ I think the Tom's in Pittsburgh have gone out of business and shipping all the way to the NW may not be a good idea either, especially if you don't have the original shipping boxes. There is a shop in NJ that has a great reputation, you might try contacting them, good luck!

http://www.ebcelectronics.com/about-us.php

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 1:07 pm
by BlueMDPicker
Thanks for the info and link! I do have all the original packing material and boxes. But, items as heavy as the amp I fear get brutal treatment from drops in transit. Hence my reluctance to even consider shipping.

The "64 Thousand Dollar Question" for me is where these repair facilities get "authorized repair manuals" for gear as esoteric as the Lightstar Reference line. Further, I wonder if there ever was such a document given the limited number of units. I would LOVE to have a schematic or repair manual. Anyone ever seen such an animal? If I had them, I'd do what I did for the amp and preamp owner's manuals: copy, post and make freely available. IMHO it would not disadvantage anyone given the length of time these beauties have been OOP.

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 1:13 pm
by kingman
natektronic wrote:So, I have been having an issue lately in my setup with my right channel cutting out. I have narrowed it down. It is the amp. I have swapped out every cable, taken the preamp out, everything. I am very worried and not sure what to do. Any advice?
I see this thread has been revived. One of mine dropped a channel and having few options, took to my local tech who has worked on many of my Carvers and Phase Linears. He fixed it and pointed out why it failed! If anyone is in a bind with similar problems, pm me and I'll hook you up.

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 4:03 pm
by Magnaryder
See Snoop's post from 26May2015. Looks like SoundSmith worked on his amp.

ray

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 5:10 pm
by BlueMDPicker
I did read that post, thanks! It would be great for Peter Ledermann to check the amp out, but that's still long haul shipping and SoundSmith is always totally backlogged (because they do such great work). I have a Dynavector MC cart there right now awaiting repair.

Re: Lightstar Owner Registration

Posted: Fri Feb 19, 2016 8:46 pm
by Snoop65
Magnaryder wrote:See Snoop's post from 26May2015. Looks like SoundSmith worked on his amp.

ray
So true Ray. Peter actually consulted Bob during the repair and made it better than original.