FAQ  •  Register   •  Gallery •  Login

It is currently Sat Dec 20, 2014 9:36 pm

Help needed ...what happened to the punch ?

<<

Butch

Newbie

Posts: 26

Joined: Sun Nov 06, 2011 11:14 am

Location: Upstate, New York

Post Sun Nov 27, 2011 5:46 pm

Help needed ...what happened to the punch ?

I've had this discussion with a few of you in the last month but ...
I have gone through two Adcom preamps in the last 4 years and decided not to purchase another Adcom product to match up with my Carver TFM-35x amplifier. To stay in suit with my amp - I found a very nice condition Carver CT-26V Preamp/Tuner. When I hooked that up it seemed like I lost alot of bottom end punch from my Klipsch LaScalas. What I did hear was alot of high end tinny / echo sound. I had to turn the treble down quite a bit and turn the bass up to about 3/4 of the knob. Sounded much better - but still not what I remember. Next step was finding an equalizer to tweak in more of what I wanted. Purchased a Kenwood GE1100 equalizer unit and heard a little difference but nothing major. Pulled the Kenwood out today and purchased a very nice ADC Sounshaper 910 computerized EQ/Analyzer. Just got done putting that in the cabinet and it sounds better than the Kenwood did - but still missing that punch in the chest ...What the hell !

Any advice on how to proceed ?
Is it the CT-26V that is causing me the issues ?
<<

radioeng2

User avatar

SILVER-7t

Posts: 1405

Joined: Fri Jan 26, 2007 7:06 pm

Location: E TN

Post Sun Nov 27, 2011 6:02 pm

Re: Help needed ...what happened to the punch ?

If there's a big equalization change from simply inserting a different preamp, then likely it's the problem and it's not right. Dried out electrolytic caps will rolloff the bottom end and cause a complaint about like you stated...being tinny sounding.

Particularly, this isn't the time to use an audio blender (a eq). If somethings wrong, then something needs fixed! It's time to investigate the units shortcomings. Actually, no time is a good time for chopping up and mutilating your audio, but that's a topic for another day. I'd suggest checking out the preamp by swapping it into another system and/or another preamp to allow temporarily pulling the CT-26.

And why a couple of failures previously? Are they too contained and running hot?

Mark
<<

Butch

Newbie

Posts: 26

Joined: Sun Nov 06, 2011 11:14 am

Location: Upstate, New York

Post Sun Nov 27, 2011 6:56 pm

Re: Help needed ...what happened to the punch ?

The problem I had with the two Adcom units is that they would turn themselves off and on erratically. Something to do with the power on button or something related to that. They were both situated in an area on my shelving rack that were well ventilated.

This system is in my garage - which is heated in the winter months and never falls below 50 degrees ...for what it's worth.

From what you're telling me, it sounds like it probably isn't a bad idea to get the preamp tested.
<<

treitz3

User avatar

"Julian"
"Julian"

Posts: 7746

Joined: Mon Oct 16, 2006 5:39 pm

Location: The tube lair in Charlotte, NC

Post Sun Nov 27, 2011 7:24 pm

Hello Butch, did you happen to switch out any interconnects when you installed the Carver preamplifier? Also, what is the condition of the surrounds on the woofers of each speaker?
In search of accurate reproduction of music. Real sound is my reference and while perfection may not be attainable? If I chase it, I might just catch excellence.

The best way to enjoy digital music reproduction is to never listen to a good analogue reproduction.

Robert R. - "Did you see my North Korea analogy? I should have named it Carversite.kim"
<<

F1nut

User avatar

SILVER-7 TUBE AMP

Posts: 4561

Joined: Tue Nov 11, 2003 3:31 am

Location: The Mars Hotel

Post Sun Nov 27, 2011 7:43 pm

Re: Help needed ...what happened to the punch ?

So, you've discovered that pre amps sound different. Welcome to the wonderful world of audio. I suggest you find something different than the Carver because obviously, it's not doing the trick.
Political Correctness...defined

A doctrine fostered by a delusional, illogical minority and rabidly promoted by an unscrupulous mainstream media, which holds forth the proposition that it is entirely possible to pick up a turd by the clean end.



In a recent press conference, President Obama remarked, "If I had a city, it would look just like Detroit."
<<

mbskeam

User avatar

SILVER-7t

Posts: 1991

Joined: Mon Jan 25, 2010 2:32 am

Location: Woodinville Wa

Post Sun Nov 27, 2011 8:00 pm

Re: Help needed ...what happened to the punch ?

I can tell you from 1st hand experience that the ct series preamps are very flat/neutral.
my ct27 needed a lot of EQ to get it to sound the way I like.
when I got a c19, I took out the EQ, I did not need it anymore, same with the sunfire tube pre, in fact it made the music sound like crap ,except when I run my sat reciver thru it does help the sound.
Mbskeam


#1 BLACK BEAUTY's made by the man, the myth, the legend Bob Carver
CARVER: TFM-75, TFM-45(3), SD/A-490T
SUNFIRE: Tube pre
2 sets of ALS'3, set of SILVERS, set of PLATS
AUDIOCONTROL: phase coupled activator
KENWOOD: BASIC M2a (2)

“Youth ages, immaturity is outgrown, ignorance can be educated, and drunkenness sobered, but stupid lasts forever.”
― Aristophanes

The only thing I'll feel......will be the RECOIL
Necronomicon Ex-Mortis....... Klaatu Barada Nikkto
"We should seek the greatest value of our action"
<<

Butch

Newbie

Posts: 26

Joined: Sun Nov 06, 2011 11:14 am

Location: Upstate, New York

Post Sun Nov 27, 2011 8:02 pm

Re:

treitz3 wrote:Hello Butch, did you happen to switch out any interconnects when you installed the Carver preamplifier? Also, what is the condition of the surrounds on the woofers of each speaker?


Didn't touch anything other than unplugging the cables from the Adcom and plugging into the Carver ...No touching of any interconnects.

The woofers look good ...no deterioration of any sort.
<<

Butch

Newbie

Posts: 26

Joined: Sun Nov 06, 2011 11:14 am

Location: Upstate, New York

Post Sun Nov 27, 2011 8:06 pm

Re: Help needed ...what happened to the punch ?

Looks like I have a very nice "looking"Carver preamp and Kenwood EQ for sale !!!
<<

mbskeam

User avatar

SILVER-7t

Posts: 1991

Joined: Mon Jan 25, 2010 2:32 am

Location: Woodinville Wa

Post Sun Nov 27, 2011 9:07 pm

Re: Help needed ...what happened to the punch ?

Didn't touch anything other than unplugging the cables from the Adcom and plugging into the Carver ...No touching of any interconnects.


yep that what I did when I made the preamp switch, sound went all to hell till I took out the EQ.
thinking I had done something wrong I redid every thing, in the end it was the CT series preamps that have the issue.
I kinda think these were Carvers 1st attempts at getting into Dolby surround, it did not turn out well
Mbskeam


#1 BLACK BEAUTY's made by the man, the myth, the legend Bob Carver
CARVER: TFM-75, TFM-45(3), SD/A-490T
SUNFIRE: Tube pre
2 sets of ALS'3, set of SILVERS, set of PLATS
AUDIOCONTROL: phase coupled activator
KENWOOD: BASIC M2a (2)

“Youth ages, immaturity is outgrown, ignorance can be educated, and drunkenness sobered, but stupid lasts forever.”
― Aristophanes

The only thing I'll feel......will be the RECOIL
Necronomicon Ex-Mortis....... Klaatu Barada Nikkto
"We should seek the greatest value of our action"

Return to Carver Home (Audio)

Who is online

Users browsing this forum: Bing [Bot], frenchguy and 2 guests

Powered by phpBB © 2011 phpBB Group.