FAQ  •  Register   •  Gallery •  Login

It is currently Sun Nov 23, 2014 12:46 am

Help Me!!

<<

mjones

Newbie

Posts: 2

Joined: Wed Oct 19, 2011 11:49 am

Post Wed Oct 19, 2011 11:57 am

Help Me!!

I am a NEW Member...I need help....

Presently, I own a Carver 1.5t amp....

I am trying to locate a good service shop for this amp....
I need to buy replacement fuses for this (10 amp, 32v)...it is not working at present....it likely is the fuse, but could involve more....
I need recommendations for a Pre-Amp-- a good match to the 1.5t....and, I want to BUY now...

I can be called at my work 1-800-951 0988 ext 210

THANK YOU!
<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13340

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Wed Oct 19, 2011 12:25 pm

Re: Help Me!!

1. WELCOME!

2. The C-1 would make an EXCELLENT preamp mate for your 1.5

3. You can get you amp serviced by consummate professionals on Carver equipment at three locations nationwide:

--Bob Carver Audio Repair in Washington state

--Rolland Barr's Hi Tech Audio Repair in Oregon

--Tom @ Vintage Hi Fi of Pittsburgh in Pennsylvania

You can find contact information here:

viewforum.php?f=4
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.
<<

kingman

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 5742

Joined: Sun Nov 30, 2008 2:10 pm

Location: Upstate South Carolina

Post Wed Oct 19, 2011 12:28 pm

Re: Help Me!!

I need to buy replacement fuses for this (10 amp, 32v)
...Try Radio Shack or your local auto parts distributor.
In reality, it only matters what it sounds like to YOU!!!
<<

TNRabbit

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 13340

Joined: Sun Jan 14, 2007 11:53 am

Location: TN Native Languishing in VA

Post Wed Oct 19, 2011 12:34 pm

Re: Help Me!!

If you blew a fuse, chances are good that there's a reason...

Where are you located?
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.
<<

thuffman03

User avatar

!! CarverFest Evictee !!

Posts: 2706

Joined: Fri Sep 19, 2008 10:07 am

Location: Pittsburgh, PA

Post Wed Oct 19, 2011 1:57 pm

Re: Help Me!!

Welcome to the forum!
Some cool Carver stuff!
<<

Scarabeo

User avatar

SILVER-7 TUBE AMP

Posts: 2653

Joined: Tue Nov 18, 2008 6:05 pm

Post Wed Oct 19, 2011 3:00 pm

Re: Help Me!!

Welcome and good luck on the fuse!
BillD, You will be forever with us! RIP until we meet again on the other side...
<<

kingman

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 5742

Joined: Sun Nov 30, 2008 2:10 pm

Location: Upstate South Carolina

Post Wed Oct 19, 2011 5:25 pm

Re: Help Me!!

Here's you a decent deal on a C-1...even got the original box! BIN $139!!!!!.....http://www.ebay.com/itm/Vintage-Carver- ... 3cbd74d362
Last edited by kingman on Thu Oct 20, 2011 2:36 am, edited 1 time in total.
In reality, it only matters what it sounds like to YOU!!!
<<

engtaz

User avatar

"TAZ"

Posts: 5244

Joined: Sat Jun 30, 2007 1:43 pm

Location: Tampa, FL

Post Thu Oct 20, 2011 2:17 am

Re: Help Me!!

Welcome
engtaz


Carver M4.0T in front channels to Caver AL VI's in SACD & 2 Channel setup
C 16, PT 2400, Slim Device, Carver TX-8, 490T and Rega TT w Grado Gold cart in the 2 channel setup
Bogen SRB20 is computer amp
Carver PM-350 donated for youth church use
<<

mjones

Newbie

Posts: 2

Joined: Wed Oct 19, 2011 11:49 am

Post Thu Oct 20, 2011 3:27 pm

Re: Help Me!!

Here is a photo of the fuse that was in the M-1.5t.... as you can see, it is blown, but it also has one end larger than the other and I have been unable to find such a thing anywhere in the Charlotte NC area (Radio Shack, Auto Supply stores, etc.), but I may be looking in the wrong place.... still need help finding this thing..... 10AMP 32 VOLT Fuse
Attachments
2011-10-20_09-15-38_467.jpg
<<

radioeng2

User avatar

SILVER-7t

Posts: 1367

Joined: Fri Jan 26, 2007 7:06 pm

Location: E TN

Post Thu Oct 20, 2011 3:40 pm

Re: Help Me!!

I most certainly could be wrong on this...you're in front of it and I'm not, but to me that looks like a regular mini fuse size with a portion of the fuse holder mechanism stuck to the one end of it.

Pardon me if wrong, and probably am. But in any case, good luck with getting it fixed up!

I'd second the likelyhood of something else being wrong...

Mark
<<

Mr. M-500t

(pair of) SILVER-7 TUBE AMPs

Posts: 6211

Joined: Fri Mar 17, 2006 10:00 pm

Post Thu Oct 20, 2011 8:53 pm

Re: Help Me!!

Looks like the guts came out of the fuse holder cap !

Return to "The Welcome Mat"

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2011 phpBB Group.