FAQ  •  Register   •  Gallery •  Login

It is currently Sat Oct 22, 2016 8:22 pm

Loud 'Pop" on CT-6 Preamp when switching input source



User avatar


Posts: 3067

Joined: Wed Sep 22, 2010 4:50 pm

Location: Snohomish, WA

Post Thu Nov 24, 2011 10:59 pm

Re: Loud 'Pop" on CT-6 Preamp when switching input source

Send it back and chew that guys ass! :x No sense it takin' in someone else's garbage and payin' 'em to do so!! [-( Lots of good working units out fairly cheap.
Sunfire Theater Grand III
Sunfire Cinema Grand Signature 405x5
Klipsch RF-5 Mains
Klipsch RC-7 Center Speaker
Sunfire 12" TrueSub EQ Signature


User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 6259

Joined: Sun Nov 30, 2008 2:10 pm

Location: Upstate South Carolina

Post Fri Nov 25, 2011 4:59 am

Re: Loud 'Pop" on CT-6 Preamp when switching input source

I'm in total agreement. Get your money back and buy another before you DO regret it!
In reality, it only matters what it sounds like to YOU!!!


User avatar

(pair of) SILVER-7t's

Posts: 2480

Joined: Fri Jan 26, 2007 7:06 pm

Location: E TN

Post Fri Nov 25, 2011 8:09 pm

Re: Loud 'Pop" on CT-6 Preamp when switching input source

This usually would indicate that DC is present where it shouldn't be. Likely a bad blocking cap. If one's bad, then it's time for all of them to be replaced.

So with a little circuit knowledge, a volt meter and a less than a $5 cap, it might be fixed. On the other hand, whatever the going rate is for a shop to do a full run thru is the other end of the spectrum. Someone that's had that done could better put a price on that than I can, but what...probably $150-200?


PS...yes, you should be concerned about spkr damage!
I was there for the 10th Carverfest! Glad you were too! Or you should have been...

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2011 phpBB Group.