MXR-150 balance

Carver Home Audio (Stereo) Discussions and Questions
Post Reply
sartor
Newbie
Posts: 8
Joined: Wed May 02, 2012 1:20 pm

MXR-150 balance

Post by sartor » Wed May 02, 2012 3:03 pm

Hi all,

Have been using my Dad's MXR-150 for a number of years now, and for a while when spinning the balance knob I'd hear a lot of static. Yet, i always seemed to get both channels just fine. Now I am getting only one channel. This came about progressively over a serveral-month period.

Can someone recommend where I might start with a repair?

thanks -

elgrau
SILVER-7 TUBE AMP
Posts: 2933
Joined: Wed May 31, 2006 9:33 pm

Re: MXR-150 balance

Post by elgrau » Wed May 02, 2012 3:39 pm

De-oxit all of the balance/volumn/tone controls?
FR: 400 disk changer with PS Audio Digital Link III DAC; Technics SL-1100A TT. QED Quenx1 IC's from DAC & TT to Adcom GTP-602 preamp/Tuner. AudioQuest King Cobra IC's from preamp to M1.0t mk-II opt2. QED Silver Spirals 4M wires to EPI 1000’s.
LR: AudioEngine wireless link from family room preamp to Barcus-Berry 2002R Sonic Maximizer to GlowPower Zyxt IC's to Sunfire 300x2 to Nordost 6M bi-source wires to AOS 28" MDF spherical speakers using six 6.5" woofers and eight 1" dome tweeters symm. arranged around the surface.
SS system: CX-995V DVD to AV-634x 3-4 channel amp (center/rears) & M1.0t mk-II opt2(fronts).
Garage: 300 disk changer to Entech 202.5 DAC to MXR150 Receiver (pre) to TFM-42 to EPI 400 speakers.

sartor
Newbie
Posts: 8
Joined: Wed May 02, 2012 1:20 pm

Re: MXR-150 balance

Post by sartor » Wed May 02, 2012 4:34 pm

haven't cracked it open yet. Dunno much about what I'm doing, but I do know how to take things apart. It's putting them back together again that gets me!

Will try the deox.
thanks.

Jason
Tempe, AZ

Post Reply

Return to “Carver Home (Audio)”