Carver a500x - One bad channel

If you have Carver repair questions, or can help other users with repairs, this is the place for it
Post Reply
ZeroG
Newbie
Posts: 8
Joined: Fri Feb 26, 2010 12:03 pm

Carver a500x - One bad channel

Post by ZeroG » Wed Jun 27, 2012 11:43 am

Hello, been a long time since I had any Carver gear, and I'm happy to find this forum again.

Recently I bought an a500x, but it has one bad channel. The relay does not kick in, but I'm not sure what the issue is. The previous owner dropped it (!!!) and broke the left channel level control handle and the input jack. I've repaired both, but the channel is still dead, though I get about 10mw dc offset from the speaker output.

I don't hear the relay on that channel click - just the other channel does. I've heard that the relays in general tend to go out, but I'm not sure that's the problem.

Can anyone advise me where to start? I've been combing the net looking for a service manual, and the closest I have found is a schematic for an a400x.

The channel that does work sounds amazing, and I'll admit that 250 wpc is intoxicating. I don't think it will take too long before I become a Carver addict.

User avatar
jjptkd
SILVER-7 TUBE AMP
Posts: 3056
Joined: Wed Sep 22, 2010 4:50 pm
Location: Snohomish, WA

Re: Carver a500x - One bad channel

Post by jjptkd » Wed Jun 27, 2012 3:32 pm

Is the bridged button pushed in? :-k
Oppo Sonica DAC
Sunfire TG-III
Sunfire 300x2
Klipsch Chorus II

User avatar
Magnaryder
SILVER-7 TUBE AMP
Posts: 3043
Joined: Fri Mar 09, 2007 1:00 am
Location: Bucyrus, Ohio

Re: Carver a500x - One bad channel

Post by Magnaryder » Wed Jun 27, 2012 11:22 pm

Welcome!!! Are there level controls and are they matched?

ray
Magnaryder

Its going to be used equipment when I sell it, so it may as well be used equipment when I buy it.

"Racing is life, the rest of the time you're just sitting around."-Steve McQueen

ZeroG
Newbie
Posts: 8
Joined: Fri Feb 26, 2010 12:03 pm

Re: Carver a500x - One bad channel

Post by ZeroG » Thu Jun 28, 2012 6:07 am

The bridge button has not been pushed in and the level controls are both at max.
I wish it was that simple. The relay does not kick in which makes me wonder if that channel is in protect mode or if the relay is bad or if it's something else.

User avatar
jjptkd
SILVER-7 TUBE AMP
Posts: 3056
Joined: Wed Sep 22, 2010 4:50 pm
Location: Snohomish, WA

Re: Carver a500x - One bad channel

Post by jjptkd » Thu Jun 28, 2012 8:31 am

Rita's Vintage Audio, home of Bob Carver, does excellent repair work. The reason I mentioned the button was because I received that exact amp damaged in shipping one time and the rear speaker terminals, volume pot and bridged button were broken from impact, which all had to be repaired. Anyway, good luck!
Oppo Sonica DAC
Sunfire TG-III
Sunfire 300x2
Klipsch Chorus II

User avatar
TNRabbit
R.I.P. Friend
R.I.P. Friend
Posts: 13360
Joined: Sun Jan 14, 2007 11:53 am
Location: TN Native Languishing in VA
Contact:

Re: Carver a500x - One bad channel

Post by TNRabbit » Thu Jun 28, 2012 10:03 am

Rita's, Vintage HiFi of Pittsburgh, & Hi-Tech Audio are all excellent repair shops. Contact info for all there are licated here on the site in a thread entitled Carver Repair. Try a search.

I'd provide the link, but I'm on my Droid & it's a PITA to do.
TNRabbit
Image

From FrankieD's lips to your ears: Sunfire - a quiet box of endless power.

Sunfire TG-IV/400~7 Amp
Carver SD/A-360 CDP
Benchmark DAC-1
Sony SACD/DVD-A
Active bi-amp: Ashly XR-1001 & 2 Rane PEQ-15s
Main: HotRodded AL-IIIs
Sub: Klipsch RT-12d
Center: Sunfire CRS-3c
Surround: Sunfire CRS-3 (x 2)

OconeeOrange wrote:"Gary likes to play it 'loud' as do I. His system begs you turn it up until you die"

RIP WIlliam B. Dibble, 1948-2012. I'll miss you my friend.

ZeroG
Newbie
Posts: 8
Joined: Fri Feb 26, 2010 12:03 pm

Re: Carver a500x - One bad channel

Post by ZeroG » Thu Jun 28, 2012 10:09 am

Thanks, I appreciate any help with this. I'm in California, so a local shop would save the shipping costs. I'd like to fix it myself if possible.

When I press the bridge button both channels go out. No schematics on line, but there is one for its bigger brother, so that might work.

Can anyone help with the relay and possible protect mode? Each channel has it's own relay, and I would suspect a short or failed component that would prevent the relay from closing, or the relay is possibly bad.

Would anyone perchance have a service manual?


Thanks!

User avatar
Magnaryder
SILVER-7 TUBE AMP
Posts: 3043
Joined: Fri Mar 09, 2007 1:00 am
Location: Bucyrus, Ohio

Re: Carver a500x - One bad channel

Post by Magnaryder » Thu Jun 28, 2012 1:23 pm

ZeroG wrote:The bridge button has not been pushed in and the level controls are both at max.
I wish it was that simple. The relay does not kick in which makes me wonder if that channel is in protect mode or if the relay is bad or if it's something else.
ZeroG: Where are you located? Perhaps someone from the forum that is close by may be of assistance.

ray
Magnaryder

Its going to be used equipment when I sell it, so it may as well be used equipment when I buy it.

"Racing is life, the rest of the time you're just sitting around."-Steve McQueen

Post Reply

Return to “CARVER Equipment Repair/Help Forum”